解决firefox 44 ssl_error_no_cypher_overlap问题

| No Comments

最近fedora23升级到firefox44之后,很多网站打不开了。经过调查发现主要是淘宝、阿里云等网站打不开,确定是ssl协议安全问题导致,firefox44完全抛弃了老的安全通信协议,一刀切了。而其它厂商的浏览器保持了这个兼容。

从安全上来说,firefox更安全了,但抛弃了用户,相反,google聪明一些,在这些协议有安全漏洞的网站则提示该网站不安全,有点逼迫网站快去更新的意思,让用户去选择浏览这个网站还是不浏览。

虽然如此,并不是意味着firefox不可以访问这些网站了,firefox粉仍然可以通过下面这些修改达到兼容目的。

(1)新建一个标签页,输入"about:config",有一个警告页面,确认要修改选项;

2016-03-10 15-46-43 的屏幕截图.png

(2)在新的页面中输入"security.tls.version.",将"security.tls.version.fallback-limit"其值由"1"修改"0",同样将"security.tls.version.min"其值由"1"修改"0",然后重启firefox即可。

Leave a comment

Archives

Pages

Powered by Movable Type 6.2.4

June 2016

Sun Mon Tue Wed Thu Fri Sat
      1 2 3 4
5 6 7 8 9 10 11
12 13 14 15 16 17 18
19 20 21 22 23 24 25
26 27 28 29 30    

Recent Assets

  • ClusterNodeAndManager.jpg
  • SampleNode.jpg
  • ClusterNode.jpg
  • SM.jpg
  • SKIPLIST.PNG
  • bitcask.jpg
  • bitcask-2.jpg
  • bitcask-1.jpg
  • LSM.JPG
  • BTREE.PNG
Creative Commons License
This blog is licensed under a Creative Commons License.

About this Entry

This page contains a single entry by Cnangel published on March 10, 2016 2:10 PM.

Firefox 45 将去除标签分组功能 was the previous entry in this blog.

Fedora 23 版本中ssh的问题 is the next entry in this blog.

Find recent content on the main index or look in the archives to find all content.